Waiting for session start


I just connected my Yamaha Montage synth to help you out testing this great new initiative.

I think I followed all steps but am not able to get it working.

1.I installed the host application and assigned the ASIO driver and correct inputs and pressed connect to make the synth available.
2. On the website I pressed the button to start a session
3. In my client app I connect to the session and it keeps saying, waiting or session start.


it seems that neither of the applications could communicate to the server properly, are you behind
a firewall or a router which blocks outgoing connections? The applications will only try to connect
to the other side for 30 seconds and then stop.

Sorry for the delay, I have a full time job doing other things, so I can only answer
in the afternoon/evening local time + weekends.

Hi Zoid,

No problem, thanks for replying to my question. I would think that outgoing connections are all open in my firewall but will retry with the full firewall disabled. Can you share some more details about the exact connections / ports required for both the client and the host to run properly?

There are no specific ports used by the client or the host, I think the range is 49000 - 65535, these are UDP ports. The applications then try to connect to the server at port 45555.

I don’t really know what could prevent the connection, I tested the connection yesterday with someone who is behind a campus hardware firewall and the connection worked ok. I know that if you are behind mobile data or some kind of a business NAT or firewall then the connection won’t work with the current system.

I found one possible problem relating to this, the server expects that you connect using IPv4 protocol but the application might find a IPv6 address for the server which means that server won’t accept these connections. I’ll change this behavior for the next version of the applications so that they always use IPv4, at least for now. This change might help also other people who have had a problem connecting to a session.

Thanks for your update Zoid. Let me know once a new version of the application is released and I will be more than happy to test again.

I updated both the client and host application with the fix. I hope that this update fixes the problem, but I cannot be certain.

Thank you zoid, I will try to test this asap and will let you know the outcome.

I now managed to connect to my own session and play my synth. I will try to make it available during the day for others to test. Another question, for program changes you will need to set MSB 64 LSB 65. However the current controls are not that friendly to directly enter this information, maybe an idea for a future update of the client?

I’ve now been able to test this with a friend logged in from a different location. It worked really well and the latency was less than expected. Great job. I will keep the Yamaha Montage online for others to play around.

Great to hear.

You are right about changing the presets, I did not consider that some synths might require setting the MSB and LSB to some other value than 0. I will try to update the client during the weekend so that you can directly input the number as well.

Ok, for this first time someone unknown is connected to my synth! This feels really strange :slight_smile: Is there any way to see who is connected and maybe a way of chatting with this person?

I think it was me, just trying out to see what the latency is like :stuck_out_tongue:

I haven’t really thought about the chatting part but we’ll see in the future if it is something that people would want.