AU plugin does not show up in Live/Garageband on macOS High Sierra

I’ve installed the AU plugin to /Library/Audio/Plug-Ins/Components but when I start Ableton Live, the plug in does not show up for me to choose. Any clues on what the issue could be?

Thanks for letting me know, I have been only able to test using the free GarageBand (Windows is my main development platform) so these issues might come up. I’ll have to see if I can get Live installed on my Mac and check what is the problem.

I was able to get the plugin to show by enabling the AU plugins on the Live preferences, ( command + , (comma)), and the file/folder tab. The AU plugins do not seem to enabled by default. However, if you already have AU plugins enabled, then the problem might be somewhere else.

I used latest Ableton Live 9 in Mac OS Sierra.

Thanks for the reply! Unfortunately the plug-in doesn’t show in Garageband for me either.

I’m using macOS High Sierra.

Ok, I’ll try to update to High Sierra and check if the plugin is visible or not.

1 Like

I tried different things but no luck unfortunately. I’ve tried:

  • Rebooting computer
  • Changing permission chmod +x for the plugin
  • Registering plugin with "pluginkit -a "
  • Changed user:group to root:staff
  • run “auval -a” to list AU but no Play-a-synth plug-in is shown

I’ve also tested installing Sprike ( which is JUCE based, which I assume Play-a-synth is as well. This application had an installer that was able to do the right thing (what ever that is) because the AU plugin showed up instantly in Garageband. Maybe you could borrow something from that project.

I was able to update to High Sierra and the plugin is still visible for me. The only thing that comes to my mind now is this: Did you copy the component file directly to “Macintosh HD/Library/Audio/Plug-Ins/Components”-folder or or the “Library/Audio/Plugin-ins/Components”-folder under your user? The plugin needs to be under the “Macintosh HD/Library”-folder.

An installer is definitely something that I will have to do, but unfortunately I have not had the time to make one.

Interesting that it works for you, but not me. I placed it in the global Macintosh HD/Library folder first but also in my local Library as well but it’s still not visible for me :confused: I’ll investigate further. Thanks for the help anyway.

It has probably something to do with the permissions or the fact that I developed the plugin on the same Mac. I can try to find out what is wrong, but Mac OS is not something that I am very familiar with.

I’m quite familiar with macOS programming but haven’t worked a lot with AUs, but if you have any code to share I might have a better chance to find a solution :slight_smile: Otherwise, is the plugin 32 or 64 bit?

The plugin is 64-bit.